anonymous Log in
Search
Recents:
v3.0
xev2
Problemas al generar WAR
03/06/12 03:20 PM

bcamargo

Replies:  8

Estimados,
EVO2
Build 54154
Java WEB
estoy con problemas al generar un WAR cada vez que intento abre la ventana
del deployment wizard para seleccionar un main, le doy NEXT y se
cuelga.....
No me pasa al generar un WAR con la EVO1 en la misma maquina.
Alguna idea???
saludos y gracias,
Bruno
Replies

acimas

03/07/12 09:49 AM
Hola Bruno,
No estoy teniendo problemas en mi caso, que error te da cuando ejecutas por
linea de comando del deployment wizard?
Para ejecutar por linea de comando parate en el directorio web, y ejecuta:
java -cp gxclassd.zip;.;GxUtils.jar com.genexus.gx.deployment.udeployw
Saludos,
Alejandro
2012/3/6 Bruno Camargo <camargob@urucan.org.uy>
> Estimados,
>
> EVO2
> Build 54154
> Java WEB
>
> estoy con problemas al generar un WAR cada vez que intento abre la ventana
> del deployment wizard para seleccionar un main, le doy NEXT y se
> cuelga.....
> No me pasa al generar un WAR con la EVO1 en la misma maquina.
>
> Alguna idea???
>
> saludos y gracias,
> Bruno
>
>
>

bcamargo

03/08/12 11:21 AM

Alejandro y Jesús,
en el directorio de mi KB
C:\KBs\GXCHLCC\JavaModel\web
tengo un bat donde puse la línea que de comando que me mandate abajo mando
un par de imagenes de lo que me da cuando presiono el boto "next".
Y desde gx evo2 cuando presiono "Next" queda colgado el java como decia el
mail anterior (tampoco me sale la consola de errores)
Me falta incluir algo de GAM parece...
Muchas gracias
saludos,
Bruno
2012/3/7 Alejandro Cimas <acimas@genexus.com>
> Hola Bruno,
>
> No estoy teniendo problemas en mi caso, que error te da cuando ejecutas
> por linea de comando del deployment wizard?
>
> Para ejecutar por linea de comando parate en el directorio web, y ejecuta:
>
> java -cp gxclassd.zip;.;GxUtils.jar com.genexus.gx.deployment.udeployw
>
> Saludos,
> Alejandro
>
>
> 2012/3/6 Bruno Camargo <camargob@urucan.org.uy>
>
>> Estimados,
>>
>> EVO2
>> Build 54154
>> Java WEB
>>
>> estoy con problemas al generar un WAR cada vez que intento abre la
>> ventana del deployment wizard para seleccionar un main, le doy NEXT y se
>> cuelga.....
>> No me pasa al generar un WAR con la EVO1 en la misma maquina.
>>
>> Alguna idea???
>>
>> saludos y gracias,
>> Bruno
>>
>>
>>
>
> --
> This message has been scanned for viruses and
> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and is
> believed to be clean.

jrodriguez

03/08/12 12:53 PM

Hola Bruno,
La advertencia que te aparece al correr el Deployment Wizard y que detallas
en la primera imagen (errorgx) se presenta, por el momento, al no incluirse
de forma automática todos los paquetes que si se listan en el classpath.
Basta con que des clic en "Ignore" y podrás construir el WAR de forma
normal, una vez generado hay que agregar esas referencias de forma manual.
El siguiente SAC contiene una lista de las clases y paquetes que se
necesitan agregar:
- http://www2.gxtechnical.com/portal/hgxpp001.aspx?15,4,61,O,S,0,,31458
Es un tema que ya estamos revisando para que este proceso se realice de
forma automática. Solo una duda, ¿Cuando corres el Deployment Wizard desde
Genexus aparece igualmente el esta advertencia antes de quedarse colgado o
no hace más?
2012/3/8 Bruno Camargo <camargob@urucan.org.uy>
> Alejandro y Jesús,
>
> en el directorio de mi KB
>
> C:\KBs\GXCHLCC\JavaModel\web
>
> tengo un bat donde puse la línea que de comando que me mandate abajo mando
> un par de imagenes de lo que me da cuando presiono el boto "next".
> Y desde gx evo2 cuando presiono "Next" queda colgado el java como decia el
> mail anterior (tampoco me sale la consola de errores)
>
> Me falta incluir algo de GAM parece...
>
> Muchas gracias
> saludos,
> Bruno
>
> 2012/3/7 Alejandro Cimas <acimas@genexus.com>
>
>> Hola Bruno,
>>
>> No estoy teniendo problemas en mi caso, que error te da cuando ejecutas
>> por linea de comando del deployment wizard?
>>
>> Para ejecutar por linea de comando parate en el directorio web, y ejecuta:
>>
>> java -cp gxclassd.zip;.;GxUtils.jar com.genexus.gx.deployment.udeployw
>>
>> Saludos,
>> Alejandro
>>
>>
>> 2012/3/6 Bruno Camargo <camargob@urucan.org.uy>
>>
>>> Estimados,
>>>
>>> EVO2
>>> Build 54154
>>> Java WEB
>>>
>>> estoy con problemas al generar un WAR cada vez que intento abre la
>>> ventana del deployment wizard para seleccionar un main, le doy NEXT y se
>>> cuelga.....
>>> No me pasa al generar un WAR con la EVO1 en la misma maquina.
>>>
>>> Alguna idea???
>>>
>>> saludos y gracias,
>>> Bruno
>>>
>>>
>>>
>>
>> --
>> This message has been scanned for viruses and
>> dangerous content by *MailScanner* <http://www.mailscanner.info/>, and
>> is
>> believed to be clean.
>
>
>

bcamargo

03/08/12 04:08 PM

No me aparece la advertencia cuando se ejecuta del deployment wizard desde
GX.
Gracias Jesus pero sigo con problemas. Incluí en la construcción del war
las librerias GAM que dice el SAC que mandaste
Luego, cuando intento entrar a la webapp me sale el cartel de login de GAM
y no puedo pasar de ahí !!! me dice
Connection not found. (GAM30)
va imagen saludos y gracias,
Bruno
El 8 de marzo de 2012 12:52, Jesús Abisay Rodriguez Vázquez <
jrodriguez@genexus.com>

sjuarez

03/08/12 04:13 PM

Bruno,
Tenemos aún pendiente el armado automático del war (mediante el war
deployment wizard), con todas las dependencias y archivos requeridos.
Para el caso del GAM, debes copiar manualmente (además de las librerías que
te indicó Jesus), los archivos connection.gam y application.gam, a la raiz
de la webapp,
saludos
2012/3/8 Bruno Camargo <camargob@urucan.org.uy>
> No me aparece la advertencia cuando se ejecuta del deployment wizard desde
> GX.
>
> Gracias Jesus pero sigo con problemas. Incluí en la construcción del war
> las librerias GAM que dice el SAC que mandaste
> Luego, cuando intento entrar a la webapp me sale el cartel de login de GAM
> y no puedo pasar de ahí !!! me dice
> Connection not found. (GAM30)
>
> va imagen saludos y gracias,
> Bruno
>
> El 8 de marzo de 2012 12:52, Jesús Abisay Rodriguez Vázquez <
> jrodriguez@genexus.com>

bcamargo

03/08/12 04:18 PM

Aclaro por las dudas (no se si es importante): solo estoy intentando una
APP web (no tienen nada de SD) y no uso JBOSS sino TOMCAT. Digo porque el
SAC hace referencia a esas condiciones...
saludos,
Bruno
El 8 de marzo de 2012 16:07, Bruno Camargo <camargob@urucan.org.uy>

jrodriguez

03/08/12 05:00 PM

No te preocupes, precisas de las clases estandard, driver de conexión y
del GAM, además de los archivos que te mencionó Sabrina, el SAC es en
efecto una referencia para el Deployment en JBoss, pero las clases listadas
son para que trabaje cualquier aplicación Java.
2012/3/8 Bruno Camargo <camargob@urucan.org.uy>
>
> Aclaro por las dudas (no se si es importante): solo estoy intentando una
> APP web (no tienen nada de SD) y no uso JBOSS sino TOMCAT. Digo porque el
> SAC hace referencia a esas condiciones...
>
> saludos,
> Bruno
>
> El 8 de marzo de 2012 16:07, Bruno Camargo <camargob@urucan.org.uy>

bcamargo

03/09/12 09:29 AM

Ahora si funcionó!
Con estos agregados al war: librerias jar + connection.gam +
application.gam
Gracias a todos,
Saludos,
Bruno
El 8 de marzo de 2012 17:00, Jesús Abisay Rodriguez Vázquez <
jrodriguez@genexus.com>


Back to xev2